Posted by: Sr Coelho | 14/08/2012

Acentuação no PL/SQL Developer

Há pouco tempo, estava com problemas com PL/SQL Developer versão 9. Tudo que eu digitava com acento, virava um caractere “?” (interrogação) . Exemplo: Área -> ao compilar -> ?rea

Achei 682 mil soluções na internet, mas nenhuma delas resolveu meu problema, até que encontrei essa solução em um site que não tinha nadar haver com meu problema, mas enfim funcionou. Então vou aproveitar o espaço pra compartilhar com os amigos.

Problema: PL/SQL Developer troca qualquer caractere acentuado pelo simbolo ” ? “.

Solução: No windows, crie uma variável de ambiente chamada NLS_LANG, com o valor .WE8ISO8859P1. Conforme figura abaixo.

Pronto! Problema resolvido. Só não sei explicar exatamente porque isso aconteceu em minha máquina (e + algumas) e em outras máquinas não. Se alguém tiver alguma pista e quiser compartilhar, seja bem vindo.


Sr. Coelho

Gostou? Visite Artigos do Sr. Coelho para mais dicas.


Responses

  1. muy bueno me ayudo muchisimo

  2. show! tambem pesquisei 1239120391031920 solucoes… porem a sua que resolveu! abs!

  3. Resolveu aqui valeu!! A primeira vez não deu certo porque eu coloquei no valor o ponto final ai deu erro na hora de iniciar,então editei a variavel e tirei o ponto e resolveu.

  4. SALVOU MINHA VIDA !!!
    Muito obrigado!

  5. Cara, muito obrigado !!!!! Parabens por compartilhar

  6. Thanks man.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: